A few bug fixes for the New Year

Happy New Year, Posthavenites. Theme engine efforts continue, with an initial internal alpha already done. More on that is coming. In the meantime, we're doing some new years cleaning and fixed a bunch of bugs. 

Maintaining software is a lot like gardening — you've got to remember sweep and weed alongside your major landscaping projects too. 

  • Strikethrough — Now you can click the Strikethrough button in the post editor which can be handy for lists you might be keeping. 
  • Private post bugs — We saw some confusion around when a private post would get published. We've made that much more clear by making the primary action on private posts say "Save Private Post" so you'll always know exactly what you're doing.  
  • Facebook Share button — It's official! The Share button is better for blog posts in terms of social media optimization. Posts show up better in Facebook when it's a share, and people are more likely to add their own comments to their timeline. It's a better experience for mobile too. So we've ditched the Like button and switched to Share 100%. 
  • Horizontal scroll bugs on mobile — Commenting and browsing on mobile should work better now that we worked through some glitches that would cause a horizontal scroll on mobile views of blog posts.
There's definitely plenty more work to do — both gardening and renovations. We'll get back to that for now. 

    As always if you hit any bugs or have further requests, let us know at help@posthaven.com. We really appreciate the support.  

    Photo via halfrain

    views
    20 responses
    Brian Wis upvoted this post.
    Thanks Gary. I'll always put in a request for the search feature. :-)
    Vasudevan Mukunth upvoted this post.
    Thank you, Gary. Request: a Markdown editor, please. :)
    Thx. Search and archive features coming with themes?? Eta??
    Markdown - yes! Your main page blog.posthaven.com still sides scrolls albeit jumpy like because this post shows up below it: http://blog.posthaven.com/posthaven-launches-po.... In it you have some long hyperlinks which cause the problem. I had to use a Google url shortener on some of my former posts to eliminate the long links (even after the fix). Now it works fine.
    Aaron Harris upvoted this post.
    Colin O'Brien upvoted this post.
    History Sleuth upvoted this post.
    Ms. Deleon upvoted this post.
    Thank you Gary. My request is about the search feature as well.
    9 visitors upvoted this post.